Flutter 安装

标签: Flutter 起步

由于我使用Windows10,所以本教程都使用Windows环境。Linux和MacOS请看官方文档。

1.系统要求

2.下载SDK

  • 1.下载稳定SDK  国内镜像谷歌官网sdk列表(如打不开需翻墙)
  • 2.解压sdk文件到你需要安装的位置,例如C:\src\flutter 。不要放到C:\Program Files\目录下,需要特殊权限
  • 3.双击flutter_console.bat进入控制台
  • 4.添加你的目录到环境变量,例如C:\src\flutter\bin 。这样就可以在系统控制台使用flutter命令了。

3.镜像设置

  • 如果你在国内使用 Flutter,创建项目会卡在“flutter package get” ,那么还需要为此设置两个环境变量:“PUB_HOSTED_URL”和“FLUTTER_STORAGE_BASE_URL”,然后再运行 Flutter 。

FLUTTER_STORAGE_BASE_URL  ====   https://storage.flutter-io.cn
PUB_HOSTED_URL  ====   https://pub.flutter-io.cn

4.运行flutter doctor

  • 打开命令行窗口输入下面的命令,检查安装环境是否部署完成
flutter doctor

5.Android环境安装

如flutter doctor结果所示,我们还需要安装安卓开发环境。

  • 安装AndriodStudio

访问官方中国网站直接下载 https://developer.android.google.cn/studio/   目前在我本机不翻墙可以访问。安装后如果提示unable to access android sdk add-on list。点击Cancel继续下一步操作后边会自动下载sdk。

  • 安装Flutter和Dart插件

打开AndroidStudio>Configure>Plugins>搜索flutter,安装flutter插件会自动安装Dart插件。

再次运行flutter doctor会发现之前的错误提示没有了。

  • 模拟器

还是推荐谷歌官方的模拟器或者真机比较稳妥,试了一下网易的mumu模拟器目前用起来还有问题(报错:Error while initializing the Dart VM: SSE2 is required)。

创建模拟器的步骤,打开Android Studio>Configure>AVD Manager>Create Virtual Device。如果电脑性能不够使用模拟器会很卡,建议使用移动设备真机。

6.使用VSCode

另外由于我的个人的喜好,推荐大家使用vscode 。官方网址 https://code.visualstudio.com/

安装vscode后,同样需要在vscode>扩展>搜索flutter,安装插件。

注意安装时勾选上 在右键菜单中显示vscode,用起来要方便得多。

本站教程大多应该会使用vscode进行开发。

至此flutter环境已基本完成,后面我们就可以进行实战开发了。


本文由 巨应教程  原创出品,转载请标明出处。